What’s Vulnerable › Vulnerabilities
CVE-2026-72849: Budibase before 3.40.0 Identity Confusion via Chat-Link Handoff CSRF
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-13 · updated 2026-10-08
- Weakness: CWE-352
Description
Budibase before 3.40.0 contains a cross-site request forgery vulnerability in the chat-link handoff endpoint that allows attackers to bind an external chat identity to a victim's account. Attackers can craft a phishing page that auto-submits a POST request with a leaked confirmation token to bind their chat identity to a victim user's account, enabling impersonation within agent operations and inheritance of victim permissions.
Affected products
- budibase server: before 3.40.0 — fixed in 3.40.0
How to fix
Upgrade to a fixed version: budibase server 3.40.0. Check the vendor advisory for mitigations.
References
- https://github.com/Budibase/budibase/security/advisories/GHSA-pvcr-8mvp-w8qr
- https://www.vulncheck.com/advisories/budibase-before-identity-confusion-via-chat-link-handoff-csrf
Get alerted when CVE-2026-72849 or the next vulnerability affects your stack