What’s Vulnerable › Vulnerabilities
CVE-2026-72851: Budibase before 3.40.0 SQL Injection via Unauthenticated Webhook
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-13 · updated 2026-10-08
- Weakness: CWE-89
Description
Budibase before 3.40.0 contains an unauthenticated SQL injection vulnerability in webhook-triggered automations with EXECUTE_QUERY steps. Attackers can POST attacker-controlled JSON to the webhook trigger endpoint to inject SQL payloads that execute with builder-configured database credentials, enabling data exfiltration, modification, and persistence in connected datasources like Snowflake.
Affected products
- budibase server: before 3.40.0 — fixed in 3.40.0
How to fix
Upgrade to a fixed version: budibase server 3.40.0. Check the vendor advisory for mitigations.
References
- https://github.com/Budibase/budibase/security/advisories/GHSA-x7h8-ww3q-xv7c
- https://www.vulncheck.com/advisories/budibase-before-sql-injection-via-unauthenticated-webhook
- https://github.com/Budibase/budibase/security/advisories/GHSA-x7h8-ww3q-xv7c
Get alerted when CVE-2026-72851 or the next vulnerability affects your stack