What’s Vulnerable › Vulnerabilities
CVE-2026-72853: Budibase before 3.40.0 SQL Injection via Oracle connector
- Severity: high (CVSS 7.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-13 · updated 2026-08-31
- Weakness: CWE-89
Description
Budibase before 3.40.0 contains a SQL injection vulnerability in the Oracle datasource connector's post-write row lookup that fails to escape table names in identifiers. Attackers with write permission on a table with a double-quote in its name can inject SQL that executes as the datasource's database user to read or modify arbitrary data.
Affected products
- budibase: before 3.40.0 — fixed in 3.40.0
How to fix
Upgrade to a fixed version: budibase 3.40.0. Check the vendor advisory for mitigations.
References
- https://github.com/Budibase/budibase/security/advisories/GHSA-xj29-x47g-9w2c
- https://www.vulncheck.com/advisories/budibase-before-sql-injection-via-oracle-connector
- https://github.com/Budibase/budibase/security/advisories/GHSA-xj29-x47g-9w2c
Get alerted when CVE-2026-72853 or the next vulnerability affects your stack