What’s Vulnerable › Vulnerabilities
CVE-2026-72855: Budibase before 3.40.0 DNS Rebinding SSRF via OpenAPI and REST
- Severity: high (CVSS 8.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-13 · updated 2026-10-08
- Weakness: CWE-918
Description
Budibase before 3.40.0 contains server-side request forgery vulnerabilities in OpenAPI query import and REST query execution that allow authenticated builder-level users to bypass DNS pinning protections through DNS rebinding attacks. Attackers can configure hostnames that resolve to public addresses during validation but resolve to loopback or private addresses during actual connection, allowing access to blocked internal HTTP services.
Affected products
- budibase server: before 3.40.0 — fixed in 3.40.0
How to fix
Upgrade to a fixed version: budibase server 3.40.0. Check the vendor advisory for mitigations.
References
- https://github.com/Budibase/budibase/security/advisories/GHSA-xg5g-26x8-cvf4
- https://www.vulncheck.com/advisories/budibase-before-dns-rebinding-ssrf-via-openapi-and-rest
Get alerted when CVE-2026-72855 or the next vulnerability affects your stack