What’s Vulnerable › Vulnerabilities
CVE-2026-72857: Budibase before 3.40.0 Credential Exposure via STRING Fields
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-13 · updated 2026-08-31
- Weakness: CWE-522
Description
Budibase before 3.40.0 fails to redact datasource credentials stored in STRING typed fields, allowing authenticated users to read MongoDB connection strings and Firebase private keys in plaintext. Attackers with table read permissions can retrieve datasource configurations through the read API to obtain live backend database credentials and service account keys.
Affected products
- budibase: before 3.40.0 — fixed in 3.40.0
How to fix
Upgrade to a fixed version: budibase 3.40.0. Check the vendor advisory for mitigations.
References
- https://github.com/Budibase/budibase/security/advisories/GHSA-6mpp-gfg5-x2vv
- https://www.vulncheck.com/advisories/budibase-before-credential-exposure-via-string-fields
- https://github.com/Budibase/budibase/security/advisories/GHSA-6mpp-gfg5-x2vv
Get alerted when CVE-2026-72857 or the next vulnerability affects your stack