What’s Vulnerable › Vulnerabilities
CVE-2026-72908: ERPNext: Possibility of SQL injection due to missing validation
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-10 · updated 2026-10-24
- Weakness: CWE-89
Description
ERPNext is a free and open source Enterprise Resource Planning tool. Prior to 15.109.0 and 16.20.0, the get_tax_template function in erpnext/accounts/doctype/tax_rule/tax_rule.py constructs an SQL WHERE clause from request-influenced posting_date and args values, allowing an authenticated low-privilege user to inject SQL and extract sensitive information. This issue is fixed in versions 15.109.0 and 16.20.0.
Affected products
- frappe erpnext: before 15.109.0; from 16.0.0, < 16.20.0
References
- https://github.com/frappe/erpnext/commit/2a91c7229a47ac6a5bb2d8227290b03415bf8baf
- https://github.com/frappe/erpnext/commit/c45d2a348777a9bdf697832b6ca129d2f0626fd2
- https://github.com/frappe/erpnext/commit/f98975f51a62d611f536368671c3dbaf81d61eb9
- https://github.com/frappe/erpnext/pull/55127
- https://github.com/frappe/erpnext/releases/tag/v15.109.0
- https://github.com/frappe/erpnext/releases/tag/v16.20.0
- https://github.com/frappe/erpnext/security/advisories/GHSA-grhp-m55m-63f8
Get alerted when CVE-2026-72908 or the next vulnerability affects your stack