What’s Vulnerable › Vulnerabilities
CVE-2026-72910: ERPNext: Unauthorised modification of master data due to missing validation
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-10 · updated 2026-10-24
- Weakness: CWE-862
Description
ERPNext is a free and open source Enterprise Resource Planning tool. Prior to 15.112.0 and 16.22.0, the merge_account, pause_job_for_doc, trigger_job_for_doc, change_release_date, and update_cost_center functions across erpnext/accounts/doctype/account/account.py, erpnext/accounts/doctype/process_payment_reconciliation/process_payment_reconciliation.py, erpnext/accounts/doctype/purchase_invoice/purchase_invoice.py, and erpnext/accounts/utils.py omit required write permission checks, allowing authenticated limited users to modify protected data beyond their roles. This issue is fixed in versions 15.112.0 and 16.22.0.
Affected products
- frappe erpnext: before 15.112.0; from 16.0.0, < 16.22.0
References
- https://github.com/frappe/erpnext/commit/2ae6451f10926bd12b6ce6c7dc40f08da83f2460
- https://github.com/frappe/erpnext/commit/8c7a313a38dfe38c9e35ca41e91389bcfaed2404
- https://github.com/frappe/erpnext/commit/ba936eefabb784805daa4c602b4baec9fc243ff8
- https://github.com/frappe/erpnext/pull/55709
- https://github.com/frappe/erpnext/releases/tag/v15.112.0
- https://github.com/frappe/erpnext/releases/tag/v16.22.0
- https://github.com/frappe/erpnext/security/advisories/GHSA-qpvh-75wh-j645
Get alerted when CVE-2026-72910 or the next vulnerability affects your stack