What’s Vulnerable › Vulnerabilities
CVE-2026-72913: Kitty: Command injection into the child shell via chained @kitty-echo + @kitty-ssh DCS escape sequences
- Severity: high (CVSS 7.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-10 · updated 2026-10-23
- Weakness: CWE-77
Description
Kitty is a cross-platform GPU based terminal. Prior to 0.48.2, the @kitty-echo and @kitty-ssh DCS handlers in kitty/window.py write unauthenticated data to the child shell's stdin, where handle_remote_echo accepts printable shell command characters and handle_remote_ssh calls get_ssh_data in kittens/ssh/utils.py, which emits a newline; chaining the handlers can execute attacker-controlled commands when a user displays untrusted terminal data. This issue is fixed in version 0.48.2.
Affected products
- kovidgoyal kitty: before 0.48.2
References
- https://github.com/kovidgoyal/kitty/commit/9dca948e9bec3c926ab3370f2cd10f9b9b10821f
- https://github.com/kovidgoyal/kitty/releases/tag/v0.48.2
- https://github.com/kovidgoyal/kitty/security/advisories/GHSA-ccp2-q4v6-rw94
- https://sw.kovidgoyal.net/kitty/changelog/#id1
- https://github.com/kovidgoyal/kitty/security/advisories/GHSA-ccp2-q4v6-rw94
Get alerted when CVE-2026-72913 or the next vulnerability affects your stack