What’s Vulnerable › Vulnerabilities
CVE-2026-73057: stoatchat before 0.15.0 Uncapped SVG Rendering Denial of Service
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-16 · updated 2026-09-24
- Weakness: CWE-400
Description
stoatchat before 0.15.0 fails to validate SVG viewBox dimensions in the proxy endpoint, allowing attackers to cause denial of service by memory exhaustion. Attackers can host malicious SVGs with extremely large width and height values and trigger concurrent requests to exhaust available memory across proxy replicas.
Affected products
- stoatchat: before 0.15.0 — fixed in 0.15.0
How to fix
Upgrade to a fixed version: stoatchat 0.15.0. Check the vendor advisory for mitigations.
References
- https://github.com/stoatchat/stoatchat/security/advisories/GHSA-x87r-h3mq-7mgr
- https://www.vulncheck.com/advisories/stoatchat-before-uncapped-svg-rendering-denial-of-service
- https://github.com/stoatchat/stoatchat/security/advisories/GHSA-x87r-h3mq-7mgr
Get alerted when CVE-2026-73057 or the next vulnerability affects your stack