What’s Vulnerable › Vulnerabilities
CVE-2026-73070: Vim: Stack Buffer Overflow in the Vim Socket Server
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-11 · updated 2026-10-29
- Weakness: CWE-121
Description
Vim is an open source, command line text editor. Prior to 9.2.0842, the socket server backend in src/socketserver.c accepts unbounded client connections in socketserver_accept(), causing descriptors to overflow fd_set structures in src/channel.c and fixed-size struct pollfd arrays in src/os_unix.c, which allows a local process that can connect to the server socket to corrupt stack memory or terminate the Vim server. This issue is fixed in version 9.2.0842.
Affected products
- vim/vim: from 9.2.0512 before 9.2.0842 — fixed in 9.2.0842
How to fix
Upgrade to a fixed version: vim/vim 9.2.0842. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/5598618b2daf8e36b3bf0251caaefcf0bf8e85e4
- https://github.com/vim/vim/releases/tag/v9.2.0842
- https://github.com/vim/vim/security/advisories/GHSA-49m8-wwxj-mr69
Get alerted when CVE-2026-73070 or the next vulnerability affects your stack