What’s Vulnerable › Vulnerabilities
CVE-2026-73073: Vim: Arbitrary Ex Command Execution in C Omni-Completion
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-18 · updated 2026-10-15
- Weakness: CWE-94
Description
Vim is an open source, command line text editor. Prior to 9.2.0845, StructMembers() in runtime/autoload/ccomplete.vim constructs and executes a vimgrep command using an insufficiently escaped typeref: or typename: value from a tags file, allowing an unterminated collection followed by a command separator to execute arbitrary Ex and operating-system commands when a user invokes C omni-completion with CTRL-X CTRL-O on a member access whose type is resolved from that tags file. This issue is fixed in version 9.2.0845.
Affected products
- vim/vim: before 9.2.0845 — fixed in 9.2.0845
How to fix
Upgrade to a fixed version: vim/vim 9.2.0845. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/2f628d8104958fa7421664f792ca6d4f7a39a10f
- https://github.com/vim/vim/releases/tag/v9.2.0845
- https://github.com/vim/vim/security/advisories/GHSA-cx73-phcg-3j5g
Get alerted when CVE-2026-73073 or the next vulnerability affects your stack