What’s Vulnerable › Vulnerabilities
CVE-2026-73075: Vim: Out-of-bounds Access in Popup Opacity Handling
- Severity: low (CVSS 3.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-11 · updated 2026-10-06
- Weakness: CWE-124
Description
Vim is an open source, command line text editor. From 9.2.0469 until 9.2.0843, popup_mark_opacity_zindex() in src/popupwin.c can use a negative w_winrow for a text-property-anchored popup with clipwindow and opacity, indexing before the screen array instead of accounting for w_popup_topoff and causing an out-of-bounds read and conditional write. This issue is fixed in version 9.2.0843.
Affected products
- vim/vim: from 9.2.0469 before 9.2.0843 — fixed in 9.2.0843
How to fix
Upgrade to a fixed version: vim/vim 9.2.0843. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/security/advisories/GHSA-pmvp-6rcj-98p4
- https://github.com/vim/vim/security/advisories/GHSA-pmvp-6rcj-98p4
- https://github.com/vim/vim/security/advisories/GHSA-pmvp-6rcj-98p4
- https://github.com/vim/vim/security/advisories/GHSA-pmvp-6rcj-98p4
Get alerted when CVE-2026-73075 or the next vulnerability affects your stack