What’s Vulnerable › Vulnerabilities
CVE-2026-73076: Vim: Arbitrary Command Execution via Malicious `.VimballRecord` Entry Replay in `vimball.vim`
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-11 · updated 2026-10-06
- Weakness: CWE-94
Description
Vim is an open source, command line text editor. Prior to 9.2.0847, runtime/autoload/vimball.vim allows a crafted vimball member named .VimballRecord to overwrite the installation record with attacker-chosen commands. When vimball#RmVimball() later processes the matching record entry, the stored Ex commands, including operating-system commands invoked through :!, execute with the privileges of the user running Vim. This issue is fixed in version 9.2.0847.
Affected products
- vim/vim: before 9.2.0847 — fixed in 9.2.0847
How to fix
Upgrade to a fixed version: vim/vim 9.2.0847. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/581a2f3ac9c6f96a26324f6b2c8c11415fd0d452
- https://github.com/vim/vim/security/advisories/GHSA-r22p-fhw4-84p2
Get alerted when CVE-2026-73076 or the next vulnerability affects your stack