What’s Vulnerable › Vulnerabilities
CVE-2026-73077: Vim: Arbitrary Code Execution via Shell Keyword Lookup
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-11 · updated 2026-10-06
- Weakness: CWE-78
Description
Vim is an open source, command line text editor. Prior to 9.2.0839, the runtime/ftplugin/sh.vim, runtime/ftplugin/zsh.vim, and runtime/ftplugin/ps1.vim filetype plugins pass attacker-controlled Visual-mode selections from K through keywordprg commands without safely separating shell arguments. fnameescape() and PATH_ESC_CHARS do not neutralize shell metacharacters before ShKeywordPrg, ZshKeywordPrg, or GetHelp invokes bash, zsh, or PowerShell, allowing arbitrary operating-system commands to execute with the privileges of the user running Vim. This issue is fixed in version 9.2.0839.
Affected products
- vim/vim: before 9.2.0839 — fixed in 9.2.0839
How to fix
Upgrade to a fixed version: vim/vim 9.2.0839. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/c5a82fe013e73c98004ad7cd4f906b1ad1ed610e
- https://github.com/vim/vim/security/advisories/GHSA-r5v6-q6j8-8qw2
Get alerted when CVE-2026-73077 or the next vulnerability affects your stack