What’s Vulnerable › Vulnerabilities
CVE-2026-73078: Vim: Arbitrary Code Execution via Netrw Menu Construction
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-11 · updated 2026-10-06
- Weakness: CWE-77
Description
Vim is an open source, command line text editor. Prior to 9.2.0840, runtime/plugin/netrwPlugin.vim loads netrw and runtime/pack/dist/opt/netrw/autoload/netrw.vim constructs Bookmarks, History, and Targets menu entries by interpolating attacker-controlled directory paths into executed :menu commands. s:NetrwBookmarkMenu(), s:NetrwTgtMenu(), g:netrw_menu_escape, EX_TRLBAR, and netrw#MakeTgt() fail to neutralize the | command separator or single quotes at five construction sites, allowing a crafted path browsed or bookmarked in GUI Vim to execute arbitrary Ex and operating-system commands. This issue is fixed in version 9.2.0840.
Affected products
- vim/vim: before 9.2.0840 — fixed in 9.2.0840
How to fix
Upgrade to a fixed version: vim/vim 9.2.0840. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/29c6fd090d4520592f8be7d9ec81190edf25ef69
- https://github.com/vim/vim/security/advisories/GHSA-rcr7-f3wr-22r2
Get alerted when CVE-2026-73078 or the next vulnerability affects your stack