What’s Vulnerable › Vulnerabilities

CVE-2026-7308: Nexus Repository 3 - Stored Cross-Site Scripting (XSS) via HTML Browse Page

Description

An authenticated user with upload permission to a hosted repository can store content that causes arbitrary JavaScript to execute in the browser of any user who browses that repository directory via the HTML index page in Sonatype Nexus Repository versions 3.6.0 through versions before 3.92.0. This could allow the attacker to perform actions in the context of the victim's session.

Affected products

How to fix

Upgrade to a fixed version: Sonatype Nexus Repository 3 3.93.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-7308 or the next vulnerability affects your stack