What’s Vulnerable › Vulnerabilities

CVE-2026-73180: Apache Tomcat: Authenticated WebSocket session survives end of HTTP session

Description

Insufficient Session Expiration vulnerability in Apache Tomcat meant that if the session ID for an authenticated HTTP session was changed after a WebSocket connection had been established under that authenticated HTTP session, the WebSokcet session would not be closed as required by the Jakarta WebSocket specification when the HTTP session ended. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.0.M1 through 9.0.120. The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.43 through 7.0.109. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Tomcat 10.1.58, 11.0.25, 9.0.121. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-73180 or the next vulnerability affects your stack