What’s Vulnerable › Vulnerabilities
CVE-2026-73192: Apache Sling XSS: XSS possible through XSSAPI.getValidHref()
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-23 · updated 2026-09-30
- Weakness: CWE-79
Description
An improper neutralization of input during web page generation ('Cross-site Scripting') [CWE-79] vulnerability when using the XSSAPI.getValidHref() in Apache Sling XSS version 2.4.10 and prior may allow an attacker to perform a reflected cross-site scripting (XSS) attack in every feature using this method. In order to successfully attack an application, the attacker needs to be able to submit a value which is not correctly sanitized by that library. Upgrade to Apache Sling XSS >= 2.4.12
Affected products
- Apache Software Foundation Apache Sling XSS: before 2.4.12 — fixed in 2.4.12
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Sling XSS 2.4.12. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-73192 or the next vulnerability affects your stack