What’s Vulnerable › Vulnerabilities
CVE-2026-73226: Electerm WebSocket `upgrade-func` and `fs` handlers allow arbitrary method/function invocation due to missing method-name allowlist
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-11 · updated 2026-09-09
- Weakness: CWE-913
Description
electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. Prior to 3.15.186, electerm allows an authenticated WebSocket client to invoke unintended internal functions through client-controlled func values in upgrade-func in src/app/server/dispatch-center.js and handleFs in src/app/server/fs.js, exposing Upgrade and fsExport methods that can execute commands, open files, mutate the filesystem, or terminate the process. This issue is fixed in version 3.15.186.
Affected products
- electerm: before 3.15.186
References
- https://github.com/electerm/electerm/commit/b1729eb67a4cd9cf1182de69dc2c8e051931740f
- https://github.com/electerm/electerm/pull/4447
- https://github.com/electerm/electerm/releases/tag/v3.15.186
- https://github.com/electerm/electerm/security/advisories/GHSA-8chw-jwc5-8587
Get alerted when CVE-2026-73226 or the next vulnerability affects your stack