What’s Vulnerable › Vulnerabilities
CVE-2026-73256: Mongoose: HTTP/1.0 detection off-by-one enables request smuggling via chunked TE
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-08-20 · updated 2026-10-18
- Weakness: CWE-444
Description
Mongoose is an embedded web server and network library. Prior to 7.22, a remote unauthenticated attacker can exploit an HTTP/1.0 reverse-proxy deployment by sending a request with Transfer-Encoding: chunked and conflicting framing. The http_cb() function in src/http.c tests hm.proto.len with an impossible greater-than-eight condition even though mg_http_parse() requires an eight-byte protocol string, so is_http_1_0 is never set. Mongoose consequently processes chunked encoding that an HTTP/1.0 proxy can ignore, enabling request smuggling and unauthorized access or state changes. This issue is fixed in version 7.22.
Affected products
- Cesanta Mongoose: before 7.22 — fixed in 7.22
How to fix
Upgrade to a fixed version: Cesanta Mongoose 7.22. Check the vendor advisory for mitigations.
References
- https://github.com/cesanta/mongoose/commit/a9df523f76f43a38bd53b4232b9cfd4c16869e71
- https://github.com/cesanta/mongoose/pull/3611
- https://github.com/cesanta/mongoose/releases/tag/7.22
- https://github.com/cesanta/mongoose/security/advisories/GHSA-mgp5-rjrv-h5j3
Get alerted when CVE-2026-73256 or the next vulnerability affects your stack