What’s Vulnerable › Vulnerabilities
CVE-2026-73260: Mongoose: Out-of-bounds Read via length-counter underflow in built-in TLS X.509 DER parser
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-20
- Weakness: CWE-125
Description
Mongoose is an embedded web server and network library. Prior to 7.23, the built-in TLS certificate parser selected by MG_TLS_BUILTIN fails to verify that a long-form DER element length fits within the remaining certificate buffer. In mg_der_to_tlv() and mg_der_next(), a peer-controlled length can advance the parser beyond the certificate and underflow the remaining uint32_t length, causing mg_tls_parse_cert_der() to continue walking an invalid pointer. An unauthenticated malicious TLS server, or a client presenting a certificate to a server configured for client certificates, can trigger an out-of-bounds read and denial of service during the handshake. This issue is fixed in version 7.23.
Affected products
- Cesanta Mongoose: before 7.23
References
- https://github.com/cesanta/mongoose/commit/a8b4ae95db3c2db85e5ad9db3fefaeebb5f7b43e
- https://github.com/cesanta/mongoose/releases/tag/7.23
- https://github.com/cesanta/mongoose/security/advisories/GHSA-f6wr-mg35-p25g
Get alerted when CVE-2026-73260 or the next vulnerability affects your stack