What’s Vulnerable › Vulnerabilities
CVE-2026-73263: Prowler: RCE on Prowler App workers via kubeconfig auth-provider cmd-path
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-12 · updated 2026-10-24
- Weakness: CWE-78
Description
Prowler is a cloud security platform. Prior to 5.36.0, the Kubernetes provider connection test accepted kubeconfig_content containing a legacy gcp auth-provider with config.cmd-path and config.cmd-args because kubeconfig_contains_exec_auth in api/src/backend/api/v1/serializers.py checked only exec blocks, and POST /api/v1/providers/{id}/connection loaded it through config.load_kube_config_from_dict in prowler/providers/kubernetes/kubernetes_provider.py, causing kubernetes-python CommandTokenSource.token to run the attacker-supplied command through subprocess.Popen on the shared worker. This issue is fixed in version 5.36.0.
Affected products
- prowler-cloud prowler: before 5.36.0
References
- https://github.com/prowler-cloud/prowler/commit/0b782fcb8c24ece7bd38deede2b8f13d8583e39c
- https://github.com/prowler-cloud/prowler/pull/12091
- https://github.com/prowler-cloud/prowler/releases/tag/5.36.0
- https://github.com/prowler-cloud/prowler/security/advisories/GHSA-ccqh-6cjc-wp4j
- https://github.com/prowler-cloud/prowler/security/advisories/GHSA-ccqh-6cjc-wp4j
Get alerted when CVE-2026-73263 or the next vulnerability affects your stack