What’s Vulnerable › Vulnerabilities
CVE-2026-73292: Semaphore UI: CSRF vulnerability on password change endpoint - No CSRF token or password confirmation
- Severity: high (CVSS 8.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-12 · updated 2026-10-24
- Weakness: CWE-352
Description
Semaphore UI is a web interface for managing DevOps tools. Prior to 2.18.21, the /api/users/{id}/password endpoint accepts a cross-site request using the authenticated user's semaphore session cookie without CSRF protection or current-password confirmation, allowing an unauthenticated attacker to change an administrator's or another user's password after user interaction. This issue is fixed in version 2.18.21.
Affected products
- semaphoreui semaphore: before 2.18.21
References
- https://github.com/semaphoreui/semaphore/commit/2d6e2e3eb10e8bf688e2ab59609b909a012fad4c
- https://github.com/semaphoreui/semaphore/commit/c59c3dc9035badcbf0609c7d35679c06e590a956
- https://github.com/semaphoreui/semaphore/releases/tag/v2.18.21
- https://github.com/semaphoreui/semaphore/security/advisories/GHSA-8cj9-r88m-8945
Get alerted when CVE-2026-73292 or the next vulnerability affects your stack