What’s Vulnerable › Vulnerabilities
CVE-2026-73300: Budibase: SQL Injection via `multipleStatements: true`
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-12 · updated 2026-09-08
- Weakness: CWE-89
Description
Budibase is an open-source low-code platform. Prior to 3.40.0, the MySQL integration component in Budibase is configured with multipleStatements: true, enabling execution of multiple SQL statements in a single query. Attackers can inject malicious SQL commands through user input fields, leading to complete database compromise. This vulnerability is fixed in 3.40.0.
Affected products
- budibase: before 3.40.0
References
- https://github.com/Budibase/budibase/releases/tag/3.40.0
- https://github.com/Budibase/budibase/security/advisories/GHSA-q6x4-v3qx-85qw
- https://github.com/Budibase/budibase/security/advisories/GHSA-q6x4-v3qx-85qw
Get alerted when CVE-2026-73300 or the next vulnerability affects your stack