What’s Vulnerable › Vulnerabilities
CVE-2026-73311: XenForo < 2.3.13 OAuth2 Authorization Code Reuse
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-09-08 · updated 2026-09-11
- Weakness: CWE-294
Description
XenForo before 2.3.13 contains an OAuth2 authorization code reuse vulnerability that allows attackers to obtain unauthorized token pairs by submitting a previously used authorization code. Attackers can exploit the failure to invalidate or mark authorization codes as consumed after initial token issuance to receive an independent token pair for the same user and scopes, bypassing the single-use guarantee of the OAuth2 authorization code flow.
Affected products
- XenForo: before 2.3.13 — fixed in 2.3.13
How to fix
Upgrade to a fixed version: XenForo 2.3.13. Check the vendor advisory for mitigations.
References
- https://bombobombone.github.io/posts/cve-2026-73311/
- https://github.com/BomboBombone/CVE-2026-73311
- https://www.vulncheck.com/advisories/xenforo-oauth2-authorization-code-reuse
- https://xenforo.com/community/threads/security-fixes-released-for-all-xenforo-and-media-gallery-versions-2-2-0-2-3-12.239856/
- https://xenforo.com/community/threads/xenforo-2-3-13-and-add-ons-released-includes-security-fixes.239857/
Get alerted when CVE-2026-73311 or the next vulnerability affects your stack