What’s Vulnerable › Vulnerabilities
CVE-2026-73418: NextAuth.js: getToken() throws an uncaught exception on malformed Bearer authorization headers
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-12 · updated 2026-09-09
- Weakness: CWE-20
Description
NextAuth.js provides authentication for Next.js. Prior to @auth/core 0.41.3 and next-auth 4.24.15 and 5.0.0-beta.32, the exported getToken() helper in the next-auth/jwt and @auth/core/jwt modules can throw an uncaught exception when it reads a malformed Authorization: Bearer header. When no session cookie is present, getToken() URL-decodes the bearer value before validating it, and malformed percent encoding causes decodeURIComponent() to throw instead of treating the token as invalid. Because getToken() is commonly called in API routes, middleware, and server-side request handlers, a single unauthenticated request can trigger an unhandled exception in code paths that authenticate requests, causing a per-request denial of service without exposing tokens, sessions, or other data and without bypassing authentication. This issue is fixed in @auth/core 0.41.3 and next-auth 4.24.15 and 5.0.0-beta.32.
Affected products
- @auth core: from 0.1.0, < 0.41.3
- nextauthjs next-auth: from 4.0.6, <= 4.24.14; from 5.0.0-beta.0, <= 5.0.0-beta.31
References
- https://github.com/nextauthjs/next-auth/commit/5bca2399a79ba8d116ca5179b4b1ebcd152e7f05
- https://github.com/nextauthjs/next-auth/commit/e707770f00c52b3479e43422b0200b059149ed53
- https://github.com/nextauthjs/next-auth/pull/13469
- https://github.com/nextauthjs/next-auth/releases/tag/%40auth%2Fcore%400.41.3
- https://github.com/nextauthjs/next-auth/releases/tag/next-auth%404.24.15
- https://github.com/nextauthjs/next-auth/releases/tag/next-auth%405.0.0-beta.32
- https://github.com/nextauthjs/next-auth/security/advisories/GHSA-xmf8-cvqr-rfgj
Get alerted when CVE-2026-73418 or the next vulnerability affects your stack