What’s Vulnerable › Vulnerabilities
CVE-2026-73483: Flowise before 3.1.3 Sandbox Escape via Puppeteer
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-08-13 · updated 2026-10-24
- Weakness: CWE-78
Description
Flowise (packages flowise and flowise-components) in versions <= 3.1.2 contain a sandbox escape in the vm2/@flowiseai/nodevm JavaScript sandbox. An authenticated user with access to the /api/v1/node-custom-function endpoint can escape the sandbox by supplying attacker-controlled executablePath and args parameters to puppeteer.launch(), which internally invokes child_process.spawn() outside the sandbox boundary. This allows execution of arbitrary OS commands as the Flowise process user (root in the official Docker image) and arbitrary host file disclosure via Chromium's file:// URL handling. In versions 3.0.8–3.1.2 exploitation requires ALLOW_BUILTIN_DEP=true; earlier versions are exploitable by default. Fixed in 3.1.3.
Affected products
- FlowiseAI Flowise: through 3.1.2
References
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-9gvv-qjj3-2p6g
- https://www.vulncheck.com/advisories/flowise-before-sandbox-escape-via-puppeteer
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-9gvv-qjj3-2p6g
Get alerted when CVE-2026-73483 or the next vulnerability affects your stack