What’s Vulnerable › Vulnerabilities
CVE-2026-73485: Flowise before 3.1.3 Remote Code Execution via Airtable Agent
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-08-13 · updated 2026-10-24
- Weakness: CWE-94
Description
Flowise before 3.1.3 contains a code injection vulnerability in the Airtable Agent node that allows unauthenticated attackers to execute arbitrary Python code by bypassing the pythonCodeValidator blocklist through obfuscation techniques. Attackers can send crafted prompts to a chatflow using the Airtable Agent node to inject malicious Python code that executes in an unsandboxed pyodide environment with full access to the host operating system.
Affected products
- FlowiseAI Flowise: before 3.1.3 — fixed in 3.1.3
How to fix
Upgrade to a fixed version: FlowiseAI Flowise 3.1.3. Check the vendor advisory for mitigations.
References
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-c5hr-rc98-xp3g
- https://www.vulncheck.com/advisories/flowise-before-remote-code-execution-via-airtable-agent
Get alerted when CVE-2026-73485 or the next vulnerability affects your stack