What’s Vulnerable › Vulnerabilities
CVE-2026-73486: Flowise before 3.1.3 Code Injection via CSV Agent customReadCSV
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-08-13 · updated 2026-10-24
- Weakness: CWE-94
Description
Flowise before 3.1.3 contains a code injection vulnerability in the CSV Agent node's customReadCSV parameter that allows authenticated attackers to execute arbitrary Python code. The validator uses a static regex blocklist that can be bypassed through obfuscation techniques, enabling attackers to execute code in the unsandboxed pyodide environment with full system access.
Affected products
- FlowiseAI Flowise: before 3.1.3 — fixed in 3.1.3
How to fix
Upgrade to a fixed version: FlowiseAI Flowise 3.1.3. Check the vendor advisory for mitigations.
References
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-4878-cqgq-j53v
- https://www.vulncheck.com/advisories/flowise-before-code-injection-via-csv-agent-customreadcsv
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-4878-cqgq-j53v
Get alerted when CVE-2026-73486 or the next vulnerability affects your stack