What’s Vulnerable › Vulnerabilities
CVE-2026-73513: Envoy: oghttp2 upstream trailers incorrect handling
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-09-21 · updated 2026-10-05
- Weakness: CWE-20
Description
Envoy is an open source edge and service proxy designed for cloud-native applications. Prior to 1.36.10, 1.37.6, 1.38.4, and 1.39.1, Envoy's optional oghttp2 upstream HTTP/2 codec accepts a response trailer HEADERS frame without END_STREAM. Envoy completes and deferred-deletes the ActiveRequest while oghttp2 keeps the stream open, leaving ClientStreamImpl with a dangling response_decoder_ reference. A later frame on the stream can dispatch through the freed object and crash the process. The relevant scope boundary is that the default nghttp2 codec rejects the malformed trailers, and the trigger is upstream-only with oghttp2 enabled. This issue is fixed in versions 1.36.10, 1.37.6, 1.38.4, and 1.39.1.
Affected products
- envoyproxy envoy: before 1.36.10; from 1.37.0 before 1.37.6; from 1.38.0 before 1.38.4; from 1.39.0 before 1.39.1 — fixed in 1.36.10, 1.37.6, 1.38.4, 1.39.1
How to fix
Upgrade to a fixed version: envoyproxy envoy 1.36.10, 1.37.6, 1.38.4, 1.39.1. Check the vendor advisory for mitigations.
References
- https://github.com/envoyproxy/envoy/commit/0d33268d7d8cdc5c8ffef462e0cceefa56156b72
- https://github.com/envoyproxy/envoy/commit/3df69eeee220d6a4088cfdd3be79b55e2e6d3514
- https://github.com/envoyproxy/envoy/commit/c4610b6c85d72ed01e014c2a1aba2934a2b774e9
- https://github.com/envoyproxy/envoy/commit/e6963c6b64cd62aa8e078ef17c76052b6e33e82b
- https://github.com/envoyproxy/envoy/releases/tag/v1.37.6
- https://github.com/envoyproxy/envoy/releases/tag/v1.38.4
- https://github.com/envoyproxy/envoy/releases/tag/v1.39.1
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-jjmm-fw8p-crpw
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-jjmm-fw8p-crpw
Get alerted when CVE-2026-73513 or the next vulnerability affects your stack