What’s Vulnerable › Vulnerabilities
CVE-2026-73515: PostGIS < 3.7.0beta2 Out-of-Bounds Read via FlatGeobuf Buffer
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-13 · updated 2026-09-24
- Weakness: CWE-125
Description
PostGIS before 3.7.0beta2 contains an out-of-bounds read vulnerability that allows attackers to cause memory disclosure or a server crash by supplying a malformed FlatGeobuf buffer. The FlatGeobuf property metadata decoder verifies that a string length field is present but fails to verify that the subsequent string body is contained within the supplied buffer before materializing it into a SQL-visible value, enabling memory disclosure or denial of service.
Affected products
- PostGIS: before 3.7.0beta2 — fixed in 3.7.0beta2
How to fix
Upgrade to a fixed version: PostGIS 3.7.0beta2. Check the vendor advisory for mitigations.
References
- https://gitea.osgeo.org/postgis/postgis/raw/tag/3.7.0beta2/NEWS
- https://mehmetince.net/part-1-6-systemic-risks-in-the-managed-postgresql-industry-extension-risks-are-real-exploiting-postgis-memory-corruption-bug-at-neondb-supabase-and-many-more/
- https://www.vulncheck.com/advisories/postgis-0beta2-out-of-bounds-read-via-flatgeobuf-buffer
Get alerted when CVE-2026-73515 or the next vulnerability affects your stack