What’s Vulnerable › Vulnerabilities
CVE-2026-73557: vLLM: Incomplete CVE-2025-62164 remediation can be bypassed by concurrent prompt parts
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-13 · updated 2026-10-15
- Weakness: CWE-362
Description
vLLM is an inference and serving engine for large language models. From 0.20.2rc0 until 0.26.0, safe_load_prompt_embeds in vllm/renderers/embed_utils.py uses torch.sparse.check_sparse_tensor_invariants, whose process-global save, enable, and restore state can be raced by concurrent prompt_embeds parts submitted to POST /v1/chat/completions through AsyncMultiModalItemTracker.resolve_items, asyncio.gather, and the default executor, allowing an invalid sparse tensor to reach tensor.to_dense despite the CVE-2025-62164 guard when enable_prompt_embeds is enabled. This issue is fixed in version 0.26.0.
Affected products
- vllm-project vllm: from 0.21.0 before 0.26.0 — fixed in 0.26.0
How to fix
Upgrade to a fixed version: vllm-project vllm 0.26.0. Check the vendor advisory for mitigations.
References
- https://github.com/vllm-project/vllm/commit/793cf79c89d4049124e756915468ac30318f2e50
- https://github.com/vllm-project/vllm/pull/48583
- https://github.com/vllm-project/vllm/releases/tag/v0.26.0
- https://github.com/vllm-project/vllm/security/advisories/GHSA-pr7f-p5mw-fc87
Get alerted when CVE-2026-73557 or the next vulnerability affects your stack