What’s Vulnerable › Vulnerabilities
CVE-2026-73602: Flowise before 3.1.3 Sandbox Escape to RCE
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-08-13 · updated 2026-10-24
- Weakness: CWE-95
Description
Flowise before 3.1.3 contains a sandbox escape vulnerability in the vm2 JavaScript sandbox that allows authenticated users to execute arbitrary code by exploiting moment locale validation bypass. Attackers can craft a fake String object with a match function that bypasses path traversal checks to load and execute malicious JavaScript files stored in the document store outside the sandbox.
Affected products
- FlowiseAI Flowise: before 3.1.3 — fixed in 3.1.3
How to fix
Upgrade to a fixed version: FlowiseAI Flowise 3.1.3. Check the vendor advisory for mitigations.
References
- https://github.com/FlowiseAI/Flowise/commit/4211bfc8f15746be4019bba557e29a7ba83d54c5
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-rqh4-rxw3-93rp
- https://www.vulncheck.com/advisories/flowise-before-sandbox-escape-to-rce
Get alerted when CVE-2026-73602 or the next vulnerability affects your stack