What’s Vulnerable › Vulnerabilities
CVE-2026-73603: Flowise before 3.1.4 Credential Abuse via Text-to-Speech
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-08-13 · updated 2026-10-24
- Weakness: CWE-862
Description
Flowise before 3.1.4 fails to validate chatflow visibility in the unauthenticated text-to-speech endpoint, allowing attackers to abuse private chatflow TTS credentials. Unauthenticated attackers can generate unlimited text-to-speech audio using stored OpenAI or ElevenLabs API keys by providing a valid chatflow UUID, incurring costs on the chatflow owner's account.
Affected products
- FlowiseAI Flowise: before 3.1.4 — fixed in 3.1.4
How to fix
Upgrade to a fixed version: FlowiseAI Flowise 3.1.4. Check the vendor advisory for mitigations.
References
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-8gj2-2cvc-6xx7
- https://www.vulncheck.com/advisories/flowise-before-credential-abuse-via-text-to-speech
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-8gj2-2cvc-6xx7
Get alerted when CVE-2026-73603 or the next vulnerability affects your stack