What’s Vulnerable › Vulnerabilities
CVE-2026-73604: Flowise before 3.1.3 Credential Exposure via API
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-08-13 · updated 2026-10-24
- Weakness: CWE-200
Description
Flowise before 3.1.3 contains an incomplete credential redaction vulnerability in the GET /api/v1/credentials/:id endpoint that returns decrypted secrets in plaintext. Authenticated users with credentials:view permission can retrieve sensitive data including database connection URLs with embedded passwords, cloud service account JSON with private keys, and API keys by calling this endpoint.
Affected products
- FlowiseAI Flowise: before 3.1.3 — fixed in 3.1.3
How to fix
Upgrade to a fixed version: FlowiseAI Flowise 3.1.3. Check the vendor advisory for mitigations.
References
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-rwrp-9823-p2xq
- https://www.vulncheck.com/advisories/flowise-before-credential-exposure-via-api
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-rwrp-9823-p2xq
Get alerted when CVE-2026-73604 or the next vulnerability affects your stack