What’s Vulnerable › Vulnerabilities
CVE-2026-73617: Budibase before 3.40.0 NoSQL Injection via MongoDB datasource
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-13 · updated 2026-10-24
- Weakness: CWE-943
Description
Budibase before 3.40.0 contains a NoSQL injection vulnerability in the MongoDB datasource integration where user-supplied parameters are enriched with handlebars using noEscaping: true and parsed without operator filtering. Attackers can inject MongoDB operators through query parameters to bypass per-user access controls, read arbitrary documents, execute JavaScript via $where operators, or modify collections through update and delete operations.
Affected products
- budibase server: before 3.40.0 — fixed in 3.40.0
How to fix
Upgrade to a fixed version: budibase server 3.40.0. Check the vendor advisory for mitigations.
References
- https://github.com/Budibase/budibase/security/advisories/GHSA-pmpg-2mxq-6xwr
- https://www.vulncheck.com/advisories/budibase-before-nosql-injection-via-mongodb-datasource
Get alerted when CVE-2026-73617 or the next vulnerability affects your stack