What’s Vulnerable › Vulnerabilities
CVE-2026-73618: Budibase Server before 3.40.0 NoSQL Injection via JSON Parameter
- Severity: high (CVSS 8.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-13 · updated 2026-10-24
- Weakness: CWE-943
Description
Budibase Server before 3.40.0 contains a NoSQL injection vulnerability in the MongoDB query execution endpoint where user-supplied parameters are interpolated into JSON query templates without proper sanitization of JSON metacharacters. Attackers with query write permission can inject JSON structural characters to alter MongoDB queries, bypassing filters to read, modify, or delete arbitrary documents.
Affected products
- budibase server: before 3.40.0 — fixed in 3.40.0
How to fix
Upgrade to a fixed version: budibase server 3.40.0. Check the vendor advisory for mitigations.
References
- https://github.com/Budibase/budibase/security/advisories/GHSA-qw6m-8fw2-2v64
- https://www.vulncheck.com/advisories/budibase-server-before-nosql-injection-via-json-parameter
- https://github.com/Budibase/budibase/security/advisories/GHSA-qw6m-8fw2-2v64
Get alerted when CVE-2026-73618 or the next vulnerability affects your stack