What’s Vulnerable › Vulnerabilities
CVE-2026-73623: GitPython before 3.1.54 Remote Code Execution via --template
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-08-13 · updated 2026-10-24
- Weakness: CWE-78
Description
GitPython before 3.1.54 contains an incomplete denylist in unsafe_git_clone_options that omits --template, allowing attackers to achieve arbitrary command execution during clone operations. Attackers can supply --template pointing to a directory containing malicious post-checkout hooks that execute when git clones the repository.
Affected products
- gitpython-developers GitPython: before 3.1.54 — fixed in 3.1.54
How to fix
Upgrade to a fixed version: gitpython-developers GitPython 3.1.54. Check the vendor advisory for mitigations.
References
- https://github.com/gitpython-developers/GitPython/security/advisories/GHSA-6p8h-3wgx-97gf
- https://www.vulncheck.com/advisories/gitpython-before-remote-code-execution-via-template
- https://github.com/gitpython-developers/GitPython/security/advisories/GHSA-6p8h-3wgx-97gf
Get alerted when CVE-2026-73623 or the next vulnerability affects your stack