What’s Vulnerable › Vulnerabilities
CVE-2026-73624: GitPython before 3.1.54 Arbitrary File Overwrite via diff
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-08-13 · updated 2026-10-24
- Weakness: CWE-88
Description
GitPython versions before 3.1.54 contain an arbitrary file overwrite vulnerability in the Diffable.diff method that fails to validate git options passed through kwargs. Attackers can supply the --output argument via the other parameter or output kwarg to write patch content to attacker-chosen file paths at process privilege level.
Affected products
- gitpython-developers GitPython: before 3.1.54 — fixed in 3.1.54
How to fix
Upgrade to a fixed version: gitpython-developers GitPython 3.1.54. Check the vendor advisory for mitigations.
References
- https://github.com/gitpython-developers/GitPython/security/advisories/GHSA-fjr4-x663-mwxc
- https://www.vulncheck.com/advisories/gitpython-before-arbitrary-file-overwrite-via-diff
- https://github.com/gitpython-developers/GitPython/security/advisories/GHSA-fjr4-x663-mwxc
Get alerted when CVE-2026-73624 or the next vulnerability affects your stack