What’s Vulnerable › Vulnerabilities
CVE-2026-73625: GitPython before 3.1.54 Remote Code Execution via kwarg value smuggling
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-08-13 · updated 2026-10-24
- Weakness: CWE-78
Description
GitPython versions before 3.1.54 contain a remote code execution vulnerability in the check_unsafe_options guard that can be bypassed by smuggling git options inside single-character kwarg values. Attackers can supply crafted option dictionaries to clone_from, fetch, pull, push, ls_remote, iter_commits, blame, or archive methods to execute arbitrary OS commands via the --upload-pack parameter.
Affected products
- gitpython-developers GitPython: before 3.1.54 — fixed in 3.1.54
How to fix
Upgrade to a fixed version: gitpython-developers GitPython 3.1.54. Check the vendor advisory for mitigations.
References
- https://github.com/gitpython-developers/GitPython/security/advisories/GHSA-r9mr-m37c-5fr3
- https://www.vulncheck.com/advisories/gitpython-before-remote-code-execution-via-kwarg-value-smuggling
Get alerted when CVE-2026-73625 or the next vulnerability affects your stack