What’s Vulnerable › Vulnerabilities
CVE-2026-73626: JupyterLab before 4.6.2 Authentication Bypass via PyPIExtensionManager
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-13 · updated 2026-09-09
- Weakness: CWE-284
Description
JupyterLab versions >=4.6.0,<=4.6.1 and <=4.5.9 contain an allowlist/blocklist enforcement gap in PyPIExtensionManager.install(). A missing 'await' caused the is_install_allowed coroutine to never execute, so the extension allowlist/blocklist check was not enforced for direct callers of install(). The stock JupyterLab HTTP API and Extension Manager UI are not affected, as they perform a separate, correctly awaited check. The issue affects only deployments where a custom extension or downstream integration imports PyPIExtensionManager and calls install() directly with a package name influenced by untrusted input, an allowlist/blocklist is configured, the PyPI Extension Manager is enabled, and kernels and terminals are disabled or delegated to remote hosts. Fixed in JupyterLab 4.6.2 and 4.5.10.
Affected products
- jupyterlab: from 4.6.0 before 4.6.1; before 4.5.10 — fixed in 4.5.10, 4.6.1
How to fix
Upgrade to a fixed version: jupyterlab 4.5.10, 4.6.1. Check the vendor advisory for mitigations.
References
- https://github.com/jupyterlab/jupyterlab/security/advisories/GHSA-whvh-wf3x-g77j
- https://www.vulncheck.com/advisories/jupyterlab-before-authentication-bypass-via-pypiextensionmanager
Get alerted when CVE-2026-73626 or the next vulnerability affects your stack