What’s Vulnerable › Vulnerabilities
CVE-2026-73627: JupyterLab 4.6.0 Plugin Manager Lock-Rule Enforcement Bypass
- Severity: medium (CVSS 6.0 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-13 · updated 2026-09-30
- Weakness: CWE-602
Description
JupyterLab (pip package 'jupyterlab') versions >=4.1.0,<=4.5.9 and >=4.6.0,<=4.6.1 contain a plugin manager lock-rule enforcement bypass. Two server-side enforcement gaps allow an authenticated user to circumvent administrator lock rules by making direct requests to the /lab/api/plugins endpoint, enabling or disabling plugins that were locked — including child plugins of multi-plugin extensions and plugins locked via the 'lock all' mechanism. This can impact data integrity and bypass hardening or restrictions (e.g., download/upload limits) implemented through locked plugins. Fixed in versions 4.6.2 and 4.5.10.
Affected products
- jupyterlab: from 4.6.0 through 4.6.1; from 4.1.0 through 4.5.9
References
- https://github.com/jupyterlab/jupyterlab/security/advisories/GHSA-h5v5-8746-g7mm
- https://www.vulncheck.com/advisories/jupyterlab-plugin-manager-lock-rule-enforcement-bypass
Get alerted when CVE-2026-73627 or the next vulnerability affects your stack