What’s Vulnerable › Vulnerabilities
CVE-2026-73633: Apache Struts: Unbounded read of a JSON request body
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-14 · updated 2026-08-18
- Weakness: CWE-400
Description
Uncontrolled resource consumption vulnerability in the JSON plugin of Apache Struts. When an application is configured to populate actions from a JSON request body, the plugin reads that body into memory without bounding how much it will accept, so a single request can exhaust the heap and deny service to other users. The plugin's configurable JSON input length limit does not bound this read. The JSON plugin is an optional component; applications that do not use it, or use it without enabling JSON request-body handling, are not affected. This issue affects Apache Struts: from 2.1.8 through 2.3.37, from 2.5.0 through 2.5.33, from 6.0.0 through 6.10.0, from 7.0.0 through 7.2.1. Users are recommended to upgrade to version 6.11.0 or 7.3.0, which fixes the issue.
Affected products
- Apache Struts: from 2.1.8 through 2.3.37; from 2.5.0 through 2.5.33; from 6.0.0 before 6.11.0; from 7.0.0 before 7.3.0 — fixed in 6.11.0, 7.3.0
How to fix
Upgrade to a fixed version: Apache Struts 6.11.0, 7.3.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-73633 or the next vulnerability affects your stack