What’s Vulnerable › Vulnerabilities

CVE-2026-73634: Apache Struts: Unbounded read of a Content Security Policy violation report

Description

Uncontrolled resource consumption vulnerability in Apache Struts. An application that exposes an endpoint collecting Content Security Policy violation reports reads the submitted report into memory without bounding how much it will accept, so a single request can exhaust the heap and deny service to other users. Such endpoints are ordinarily reachable without authentication. The core distribution maps no such endpoint by default; applications that do not collect violation reports are not affected. This issue affects Apache Struts: from 6.0.0 through 6.10.0, from 7.0.0 through 7.2.1. Users are recommended to upgrade to version 6.11.0 or 7.3.0, which fixes the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Struts 6.11.0, 7.3.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-73634 or the next vulnerability affects your stack