What’s Vulnerable › Vulnerabilities
CVE-2026-73635: Apache Struts: Unbounded growth of localized-text caches driven by the request locale
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-15 · updated 2026-08-18
- Weakness: CWE-770
Description
Allocation of resources without limits or throttling vulnerability in Apache Struts. When no fixed locale is configured, the locale used for localized-text lookups is taken from the incoming request, allowing an unauthenticated remote client to cause the framework's internal localized-text caches to grow without bound and exhaust the Java heap, denying service to other users. Applications that configure a fixed locale are not affected. This issue affects Apache Struts: from 2.0.0 through 2.3.37, from 2.5.0 through 2.5.33, from 6.0.0 through 6.10.0, from 7.0.0 through 7.2.1. Users are recommended to upgrade to version 6.11.0 or 7.3.0, which fixes the issue.
Affected products
- Apache Struts: from 2.0.0 through 2.3.37; from 2.5.0 through 2.5.33; from 6.0.0 before 6.11.0; from 7.0.0 before 7.3.0 — fixed in 6.11.0, 7.3.0
How to fix
Upgrade to a fixed version: Apache Struts 6.11.0, 7.3.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-73635 or the next vulnerability affects your stack