What’s Vulnerable › Vulnerabilities

CVE-2026-7427: Allocation of Resources Without Limits or Throttling in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.5 before 19.0.6, 19.1 before 19.1.4, and 19.2 before 19.2.2 that under certain conditions could have allowed an unauthenticated user to cause a denial of service due to improper input validation.

Affected products

How to fix

Upgrade to a fixed version: GitLab 19.0.6, 19.1.4, 19.2.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-7427 or the next vulnerability affects your stack