What’s Vulnerable › Vulnerabilities

CVE-2026-7471: Server-Side Request Forgery (SSRF) in GitLab

Description

GitLab has remediated an issue in GitLab EE affecting all versions from 18.8 before 18.9.7, 18.10 before 18.10.6, and 18.11 before 18.11.3 that could have allowed an authenticated user with control of a virtual registry upstream to make requests to internal hosts due to improper validation.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.10.6, 18.11.3, 18.9.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-7471 or the next vulnerability affects your stack