What’s Vulnerable › Vulnerabilities
CVE-2026-7474: Nomad vulnerable to path traversal in dynamic host volume which may lead to code execution
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-12 · updated 2026-10-26
- Weakness: CWE-22
Description
HashiCorp Nomad and Nomad Enterprise prior to 2.0.1 are vulnerable to code execution on the client host through a path traversal attack. This vulnerability (CVE-2026-7474) is fixed in Nomad 2.0.1, 1.11.5 and 1.10.11.
Affected products
- HashiCorp Nomad Enterprise: from 1.10.0 before 2.0.1 — fixed in 2.0.1
How to fix
Upgrade to a fixed version: HashiCorp Nomad Enterprise 2.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-7474 or the next vulnerability affects your stack