What’s Vulnerable › Vulnerabilities

CVE-2026-74761: Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Spoofing of RemoveSubscription clientId

Description

Improper input validation in TopicRegion in Apache ActiveMQ, Apache ActiveMQ Broker, and Apache ActiveMQ All on all platforms. An authenticated client can spoof clientId when removing a durable topic subscription. This issue affects Apache ActiveMQ Broker: before 5.19.11, from 6.0.0 before 6.3.2; Apache ActiveMQ All: before 5.19.11, from 6.0.0 before 6.3.2; Apache ActiveMQ: before 5.19.11, from 6.0.0 before 6.3.2. Users are recommended to upgrade to version 6.3.2 or 5.19.11 which fixes the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache ActiveMQ 5.19.11, 6.3.2; Apache Activemq All 5.19.11, 6.3.2; Apache Activemq Broker 5.19.11, 6.3.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-74761 or the next vulnerability affects your stack