What’s Vulnerable › Vulnerabilities
CVE-2026-74784: Scriban before 7.2.0 Denial of Service via array.insert_at
- Severity: high (CVSS 8.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-16 · updated 2026-08-31
- Weakness: CWE-770
Description
Scriban before 7.2.0 contains a denial of service vulnerability in the array.insert_at function that allocates unbounded null entries without respecting LoopLimit or LimitToString constraints. Attackers can supply a large index parameter to trigger OutOfMemoryException and crash the host process in under a second.
Affected products
- scriban: before 7.2.0 — fixed in 7.2.0
How to fix
Upgrade to a fixed version: scriban 7.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/scriban/scriban/security/advisories/GHSA-24c8-4792-22hx
- https://www.vulncheck.com/advisories/scriban-before-denial-of-service-via-array-insert-at
Get alerted when CVE-2026-74784 or the next vulnerability affects your stack